summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 16:37:18 +0800
committerSainnhepark2020-07-28 16:37:18 +0800
commit1d7dc24010084f3957256735e2ac02683a710b83 (patch)
treec4584e33e528c18f1b0a00a954a9d8fb0f17f2ea /PKGBUILD
parent631be7c988a3cb29580fbb8f50750e4f6fc28f11 (diff)
downloadaur-1d7dc24010084f3957256735e2ac02683a710b83.tar.gz
update build()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 690ff5f04148..c65cb5ef0eca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ yarn install --frozen-lockfile --production
}
package() {
- cd "${srcdir}/${_extname}"
- find ftplugin lib/*.js package.json python syntax -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}