summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 09:13:28 +0800
committerSainnhepark2020-07-28 09:13:28 +0800
commitda5064c1f2d3e982c55eea618aa882c9e792bc00 (patch)
tree453beb80c8209b57ec219a2a8744a80999c8a8c0 /PKGBUILD
downloadaur-da5064c1f2d3e982c55eea618aa882c9e792bc00.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a27cddde4f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgbase=neovim-coc-sources-git
+pkgname=('neovim-coc-syntax-git'
+ 'neovim-coc-tag-git'
+ 'neovim-coc-dictionary-git')
+arch=('any')
+url='https://github.com/neoclide/coc-sources'
+makedepends=('git')
+license=('')
+groups=('neovim-coc-extras-git')
+source=("coc-sources::git+${url}.git")
+pkgver=1.2.5.r0.ga2f059e
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/coc-sources"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package_neovim-coc-syntax-git() {
+ _extname=syntax
+ pkgdesc='Syntax words completion source for coc.nvim'
+ depends=('neovim-coc')
+ _packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+ provides=("neovim-coc-${_extname}")
+ conflicts=("neovim-coc-${_extname}")
+ cd "${srcdir}/coc-sources/packages/${_extname}"
+ find . -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}
+
+package_neovim-coc-tag-git() {
+ _extname=tag
+ pkgdesc='tag source for coc.nvim'
+ depends=('neovim-coc')
+ _packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+ provides=("neovim-coc-${_extname}")
+ conflicts=("neovim-coc-${_extname}")
+ cd "${srcdir}/coc-sources/packages/${_extname}"
+ find . -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}
+
+package_neovim-coc-dictionary-git() {
+ _extname=dictionary
+ pkgdesc='dictionary source for coc.nvim'
+ depends=('neovim-coc')
+ _packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+ provides=("neovim-coc-${_extname}")
+ conflicts=("neovim-coc-${_extname}")
+ cd "${srcdir}/coc-sources/packages/${_extname}"
+ find . -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}