summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Walch2015-10-27 08:34:35 +0100
committerFlorian Walch2015-10-27 08:40:40 +0100
commit49a449ba1cc957a0e6a05f5d480d9ebafee23dd5 (patch)
treea247a007a0e1b2172464a4dd5ead72bcfc246abd /PKGBUILD
parentd8350608354fcc3fd8206a7a72f84242f072e2d0 (diff)
downloadaur-49a449ba1cc957a0e6a05f5d480d9ebafee23dd5.tar.gz
PKGBUILD: Set ENABLE_JEMALLOC, update to 0.r4306.68e5968.
jemalloc is no longer enabled by default [1]. Also update website URL to use HTTPS. [1] https://github.com/neovim/neovim/pull/3515
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 331377c61a36..f8c32a133c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Contributor: Florian Hahn <flo@fhahn.com>
pkgname=neovim-git
-pkgver=0.r4069.cd6b4af
+pkgver=0.r4306.68e5968
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs.'
arch=('i686' 'x86_64')
-url='http://neovim.io'
+url='https://neovim.io'
license=('custom:neovim')
depends=('jemalloc' 'libtermkey' 'libuv' 'libvterm-bzr' 'msgpack-c' 'unibilium')
makedepends=('cmake' 'git' 'luajit' 'lua51-messagepack' 'lua51-lpeg')
@@ -28,8 +28,11 @@ pkgver() {
build() {
mkdir -p "${pkgname}/build"
cd "${pkgname}/build"
- cmake -G 'Unix Makefiles' -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -G 'Unix Makefiles' \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_JEMALLOC=ON \
+ ..
make
}