summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlisk2017-10-09 06:39:08 +0200
committerFlisk2017-10-09 06:40:58 +0200
commit9a264ba4194e6e605a381c3ac8111945b7ddc345 (patch)
tree232023b10f47722f2015a2b8acc75e1607e0d12f /PKGBUILD
downloadaur-9a264ba4194e6e605a381c3ac8111945b7ddc345.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c0d84e49659
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname="neovim-gtk"
+_pkgname="neovim-gtk"
+pkgdesc="GTK ui for neovim written in rust using gtk-rs bindings. With ligatures support."
+pkgver=v0.1.1
+pkgrel=1
+depends=('gtk3')
+arch=('x86_64' 'i686')
+url="https://github.com/daa84/neovim-gtk"
+license=('GPL3')
+makedepends=('rust' 'cargo' 'git')
+source=("$_pkgname::git+https://github.com/daa84/neovim-gtk.git")
+sha256sums=('SKIP')
+
+package() {
+ cd "$_pkgname"
+
+ env CARGO_INCREMENTAL=0 cargo build --release
+
+ install -D -m755 "$srcdir/$_pkgname/target/release/nvim-gtk" \
+ "$pkgdir/usr/bin/nvim-gtk"
+
+ install -D -m755 "$srcdir/$_pkgname/desktop/org.daa.NeovimGtk.desktop" \
+ "$pkgdir/usr/share/applications/org.daa.NeovimGtk.desktop"
+
+ install -D -m755 "$srcdir/$_pkgname/desktop/org.daa.NeovimGtk.png" \
+ "$pkgdir/usr/share/pixmaps/org.daa.NeovimGtk.png"
+}