summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormidgard2017-08-13 18:48:57 +0200
committermidgard2017-08-13 18:55:30 +0200
commit14a35f14a2ddf64d254829fe3e10f6534da24459 (patch)
treef1185339b9cbc533c905426c4aacd45a1cfbabeb /PKGBUILD
downloadaur-14a35f14a2ddf64d254829fe3e10f6534da24459.tar.gz
Initial commit
Based on the PKGBUILD file of the kotlin-vim AUR package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16d7e1e5a8d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: midgard <arch dot midgard "at symbol" janmaes "youknowwhat" com>
+# Contributor: Kirill Klenov <horneds@gmail.com>
+# Contributor: Mikhail felixoid Shiryaev <mr dot felixoid na gmail com>
+
+pkgname=neovim-kotlin
+pkgver=r55.01e3a4c
+pkgrel=1
+pkgdesc='NeoVim plugin for Kotlin'
+arch=('any')
+license=('LGPL3')
+url='https://github.com/udalov/kotlin-vim'
+depends=('neovim')
+source=("git+https://github.com/udalov/kotlin-vim.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/kotlin-vim"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/kotlin-vim"
+
+ local i
+ for i in syntax indent ftdetect; do
+ install -Dm644 ${i}/kotlin.vim "${pkgdir}/usr/share/nvim/runtime/${i}/kotlin.vim"
+ done
+}
+
+# vim:set ts=2 sw=2 tw=100 et: