summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Feletto2020-08-24 13:58:33 +0200
committerAndrea Feletto2020-08-24 13:58:33 +0200
commit306be64bcb7d2da14bf921b0498c574878f8aedc (patch)
tree1dbcc0fc8c1d3eea691beb784ec4176ec1a666d4 /PKGBUILD
downloadaur-306be64bcb7d2da14bf921b0498c574878f8aedc.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c61fbd2e9fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# neovim-man
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=neovim-man-git
+_pkgname=${pkgname%-*}
+pkgver=v0.1.0.r30.gcfdc78f
+pkgrel=1
+pkgdesc='View man pages in neovim. Grep for the man pages.'
+arch=('any')
+url='https://github.com/vim-utils/vim-man'
+license=('custom')
+depends=('neovim')
+source=(
+ "$_pkgname::git+https://github.com/vim-utils/vim-man"
+ 'https://raw.githubusercontent.com/vim/vim/master/LICENSE'
+)
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ runtime="$pkgdir/usr/share/nvim/runtime"
+ licenses="$pkgdir/usr/share/licenses"
+
+ cd "$srcdir/$_pkgname"
+ install -dv "$runtime"
+ cp -R autoload doc ftplugin plugin syntax "$runtime/"
+ install -Dvm644 "$srcdir/LICENSE" "$licenses/$_pkgname/LICENSE"
+}
+