summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzenekron2018-04-24 22:09:14 +0200
committerzenekron2018-04-24 22:17:25 +0200
commit2743cfa72e7569c57cb09efdacf82becc96cd45a (patch)
treeaec7cff62ee9b63d37cf1ef855d5d7e20c78dfda /PKGBUILD
downloadaur-2743cfa72e7569c57cb09efdacf82becc96cd45a.tar.gz
add PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29b8a8dfe059
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: zenekron <zenekron@gmail.com>
+
+pkgname=neovim-plug-git
+pkgver=r608.e6a775e
+pkgrel=1
+pkgdesc="Minimalist Neovim Plugin Manager"
+url="https://github.com/junegunn/vim-plug"
+license=("MIT")
+source=("$pkgname::git+https://github.com/junegunn/vim-plug")
+md5sums=("SKIP")
+arch=("any")
+depends=("neovim")
+conflicts=("neovim-plug")
+provides=("neovim-plug")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm 644 "plug.vim" \
+ "$pkgdir/usr/share/nvim/runtime/autoload/plug.vim"
+ install -Dm 644 "LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set ts=4 sw=4: