summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-12-16 11:31:39 -0600
committerLuis Martinez2021-12-16 11:31:39 -0600
commit8ad094e86f36d0aacbd84a6e7d664915531ffdd7 (patch)
tree4132501b85f9bd6d3099a5fb2b7bd9c24b3f7f89 /PKGBUILD
downloadaur-8ad094e86f36d0aacbd84a6e7d664915531ffdd7.tar.gz
initial commit based on neovim-renamer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..875013824f0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-renamer-git
+pkgver=3.0.3.r0.g3e9f083
+pkgrel=1
+pkgdesc="VSCode-like renaming for Neovim"
+arch=('any')
+url="https://github.com/filipdutescu/renamer.nvim"
+license=('Apache')
+groups=('neovim-plugins')
+depends=('neovim' 'neovim-plenary')
+makedepends=('git')
+install=renamer.install
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc lua plugin \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}