summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-11-27 13:54:22 -0600
committerLuis Martinez2021-11-27 13:54:22 -0600
commite3bd84eca04c12c9e258c57df0d17609e02b3928 (patch)
tree073d091b109a2bdd7526b834b38e5a5a24ea9c1e /PKGBUILD
parentc6ccbb49f86941a11aadde83db9a56090a0b2f51 (diff)
downloadaur-e3bd84eca04c12c9e258c57df0d17609e02b3928.tar.gz
package cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23b0a49b7a20..3c0f83dedede 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=neovim-telescope-git
-pkgver=r598.c5a6ed1
-pkgrel=3
-pkgdesc="A highly extensible fuzzy finder for lists"
+pkgver=r806.492f1d3
+pkgrel=1
+pkgdesc="Extensible fuzzy finder for lists"
arch=('any')
url="https://github.com/nvim-telescope/telescope.nvim"
license=('MIT')
groups=('neovim-plugins')
-depends=('neovim>=0.5.0' 'neovim-plenary' 'neovim-popup')
-optdepends=('bat: for inline previews'
- 'fd'
- 'ripgrep'
- 'neovim-tree-sitter'
- 'vim-devicons')
+depends=('neovim' 'neovim-plenary' 'neovim-popup')
+optdepends=(
+ 'bat: for inline previews'
+ 'fd'
+ 'ripgrep'
+ 'neovim-tree-sitter'
+ 'vim-devicons')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -28,8 +29,10 @@ pkgver() {
package() {
cd "$pkgname"
- find data doc lua plugin -not \( -path lua/tests -prune \) \
- -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ find data doc lua plugin \
+ -not \( -path lua/tests -prune \) \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}