summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShane Stone2020-05-13 01:15:07 -0700
committerShane Stone2020-05-13 01:15:07 -0700
commit7ab7c34e3c63a2ee23c4a9b2e1ac9f78c3ae1da8 (patch)
tree8b25098c2f42ebd819f1f852b2473f7802139808 /PKGBUILD
downloadaur-7ab7c34e3c63a2ee23c4a9b2e1ac9f78c3ae1da8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3334b740c199
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=neovim-togglelist-opt-git
+_pkgname=togglelist
+pkgver=12.cafedc4
+pkgrel=1
+pkgdesc='Functions to toggle the Location List and the Quickfix List windows.'
+arch=('any')
+url="https://github.com/milkypostman/vim-${_pkgname}"
+license=('custom:vim')
+depends=('neovim')
+makedepends=('git')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rvt "${pkgdir}/${_installpath}" plugin
+
+}