summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShane Stone2024-02-13 20:20:47 -0500
committerShane Stone2024-02-13 20:20:47 -0500
commitb9b05dc8ab520e9cbbe9cddd666fe6eb8cc75998 (patch)
tree8161a8b3939ecd727515b5290f10849e56409c78 /PKGBUILD
downloadaur-b9b05dc8ab520e9cbbe9cddd666fe6eb8cc75998.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d15b17de763b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=neovim-which-key-opt-git
+_pkgname=which-key
+pkgver=335.4433e5e
+pkgrel=1
+pkgdesc=''
+arch=('any')
+url="https://github.com/folke/${_pkgname}.nvim"
+license=('Apache')
+depends=('neovim')
+makedepends=('git')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rt "${pkgdir}/${_installpath}" doc lua plugin
+
+}