summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChih-Hsuan Yen2019-01-28 22:02:24 +0800
committerChih-Hsuan Yen2019-01-28 22:02:24 +0800
commit7b4d35d82e05fcc134fc97c48a4e4cb71bb518e8 (patch)
treee156376991dc90507fcd43d9826664a077babb94 /PKGBUILD
parentd2fc5ac16964f6e2d09809a61ab1a055ae1c7ead (diff)
downloadaur-7b4d35d82e05fcc134fc97c48a4e4cb71bb518e8.tar.gz
adapt to new clang folder layout
Ref: https://github.com/Valloric/ycmd/pull/1172 Other changes: * Go back to the submodule commit for ycmd * Make sure system headers/libs are used * Skip removal of CMakeFiles - they won't appear in out-of-source builds * Improve `cp` commands
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1a82bd89210..8cfcab3ff183 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Contributor: Daniel Micay <danielmicay@gmail.com>
pkgname=neovim-youcompleteme-core-git
-pkgver=r2459.c209cdbb
+pkgver=r2478.c25e449f
pkgrel=1
pkgdesc='A code-completion engine for Vim'
arch=(i686 x86_64)
@@ -19,7 +19,7 @@ depends=('neovim' 'boost-libs' 'python>=3.2' 'clang>=6.0'
'python-bottle' 'python-waitress' 'python-frozendict'
'python-requests-futures' 'python-future' 'python-neovim'
'python-regex')
-makedepends=('git' 'cmake' 'boost')
+makedepends=('git' 'cmake' 'boost' 'pybind11')
optdepends=(
'gocode-git: Go semantic completion'
'godef-git: Go semantic completion'
@@ -50,7 +50,9 @@ prepare() {
git config submodule.third_party/ycmd.url "$srcdir/ycmd"
git submodule update
- git -C third_party/ycmd checkout master
+ # Force system headers/libs
+ cd third_party/ycmd/cpp
+ rm -rf BoostParts llvm pybind11
}
build() {
@@ -72,11 +74,10 @@ package() {
cd YouCompleteMe
install -Ddm755 "$pkg_ycmd_dir"
- cp -r autoload doc plugin python "$pkgdir/usr/share/nvim/runtime"
- cp -r third_party/ycmd/{ycmd,ycm_core.so,CORE_VERSION} "$pkg_ycmd_dir"
- clang_version="$(clang --version|sed -n 's/clang version \([0-9.]\+\) .*/\1/p')"
- ln -s "/usr/lib/clang/$clang_version/include/" "$pkg_ycmd_dir/clang_includes"
- unset clang_version
+ cp -dr --no-preserve=ownership autoload doc plugin python "$pkgdir/usr/share/nvim/runtime"
+ cp -dr --no-preserve=ownership third_party/ycmd/{ycmd,ycm_core.so,CORE_VERSION} "$pkg_ycmd_dir"
+ install -Ddm755 "$pkg_ycmd_dir/third_party/clang/"
+ ln -s /usr/lib "$pkg_ycmd_dir/third_party/clang/lib"
install -Ddm755 "$pkg_ycmd_dir/third_party/tern_runtime/node_modules/"
install -Ddm755 "$pkg_ycmd_dir/third_party/gocode/"
@@ -85,7 +86,7 @@ package() {
ln -s /usr/bin/gocode "$pkg_ycmd_dir/third_party/gocode/"
ln -s /usr/bin/godef "$pkg_ycmd_dir/third_party/godef/"
- find "$pkgdir" \( -name .git -or -name 'test*' -or -name 'run_tests.py' -or -name 'CMakeFiles' \) -exec rm -fr {} +
+ find "$pkgdir" \( -name .git -or -name 'test*' -or -name 'run_tests.py' \) -exec rm -fr {} +
python -m compileall -d /usr/share/nvim/runtime "$pkgdir/usr/share/nvim/runtime"
python -O -m compileall -d /usr/share/nvim/runtime "$pkgdir/usr/share/nvim/runtime"