summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Antoniou2020-02-29 01:14:11 +0200
committerThomas Antoniou2020-02-29 01:14:11 +0200
commit2899292eda03fd8c9bb8a5ef923bf1d8a2cad49f (patch)
treee16a069fcb93779aa5222888f8dfcfa4b1e4d813 /PKGBUILD
downloadaur-nerd-fonts-hermit.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a3199d21a6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Thomas Antoniou <info@quelotic.dev>
+
+pkgname=nerd-fonts-hermit
+pkgver=2.1.0
+pkgrel=2
+pkgdesc="Patched font Hermit (Hurmit) from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=("MIT")
+makedepends=("fontconfig")
+source=("Hermit-$pkgver.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Hermit.zip"
+ "https://raw.githubusercontent.com/ryanoasis/nerd-fonts/$pkgver/LICENSE")
+sha256sums=("551fcb801963cd5ced87a85d135589053bbd23b6f5674ddb985d9e50b2bc49c6"
+ "d2a29823384e9194a87936ccad495c764c2ef733b29bfa6f72a1d65803ce02e5")
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}