summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorD3SOX2021-06-08 13:18:12 +0200
committerD3SOX2021-06-08 13:18:12 +0200
commitb194eed6ca83042e34b830eb53d6479fc4f2fe03 (patch)
tree00a2b90805e47389dc0b25f0bb099854a18a1b77 /PKGBUILD
parent22f344b76f5da3ad072e1d5ea6ed51abf656ebbb (diff)
downloadaur-b194eed6ca83042e34b830eb53d6479fc4f2fe03.tar.gz
use absolute glyph directory
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc32196a79bd..7fd6b098c14a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=nerd-fonts-sf-mono
pkgver=2.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Monospaced variant of San Francisco. Sourced directly from Apple, patched with the Nerd Fonts Patcher"
arch=('any')
url='https://developer.apple.com/fonts/'
@@ -9,13 +9,13 @@ license=('custom')
makedepends=('git' 'p7zip' 'python' 'fontforge' 'subversion')
conflicts=('nerd-fonts-sf-mono')
provides=('nerd-fonts-sf-mono')
-source=('https://developer.apple.com/design/downloads/SF-Mono.dmg' "https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v$pkgver/font-patcher" "svn+https://github.com/ryanoasis/nerd-fonts/tags/v$pkgver/src/glyphs")
-sha256sums=('ec0518e310797d2f9cb924c18e3e7b661359f4fb653d1ad4315758ebcdb5ff11' '3377615be4271f8bdeef66e6f2f82ac3f3cfb7b5677abe7b8e189409da048859' 'SKIP')
+source=('https://developer.apple.com/design/downloads/SF-Mono.dmg' "font-patcher-$pkgver::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v$pkgver/font-patcher" "allow-glyphdir.diff" "svn+https://github.com/ryanoasis/nerd-fonts/tags/v$pkgver/src/glyphs")
+sha256sums=('ec0518e310797d2f9cb924c18e3e7b661359f4fb653d1ad4315758ebcdb5ff11' '3377615be4271f8bdeef66e6f2f82ac3f3cfb7b5677abe7b8e189409da048859' '6fad8dead6215b1d8cedbbce3d1bc1fc7c1b0bb06ea70518334bd443a7ba543f' 'SKIP')
build() {
- # prepare glyphs so that font-patcher can find them
- mkdir -p "$srcdir/src"
- ln -sf "$srcdir/glyphs" "$srcdir/src/glyphs"
+ _patcher="font-patcher-$pkgver-glyphdir"
+ # apply patch to font-patcher to allow using custom glyph directory
+ patch -p1 --follow-symlinks -o "$_patcher" < allow-glyphdir.diff
# remove previous files
rm -rf SFMonoFonts
# extract dmg
@@ -29,7 +29,7 @@ build() {
for f in "$srcdir/Library/Fonts"/*.otf; do
printf "%b" "\e[1;32m==> \e[0mNow patching $f\n"
# patch font quiet with complete single-width glyphs
- python "$srcdir/font-patcher" -q -c -s "$f" -out "$srcdir/patched" > /dev/null
+ python "$srcdir/$_patcher" --glyphdir "$srcdir/glyphs/" -q -c -s "$f" -out "$srcdir/patched" &> /dev/null
done
}