summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAgustin Carrasco2018-10-03 01:54:02 -0300
committerAgustin Carrasco2018-10-03 01:54:02 -0300
commit0ec43f8397e69ecf4de6b4872f785846b5a639c4 (patch)
tree0eeb016daf2ce48d1c518e2cc7a35a8e238965c1 /PKGBUILD
downloadaur-0ec43f8397e69ecf4de6b4872f785846b5a639c4.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfc00cb9df7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Agustin Carrasco <asermax at gmail dot com>
+pkgname=nerd-fonts-ubuntu-mono
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Patched font UbuntuMono from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-inconsolata')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/UbuntuMono.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=('577219591b69ef05e539e19e716a01412a560633'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}