summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorprg3182016-08-23 17:06:01 -0400
committerprg3182016-08-23 17:06:01 -0400
commit623eacbdcf6f3e27d2a933c42652a238222d9bb5 (patch)
tree596496ec7307209ea56821606fdb2d4a256b2f47 /PKGBUILD
downloadaur-nesasm-git.tar.gz
initial commmit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb4dfca438cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
+# Contributor: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
+pkgname=nesasm-git
+_pkgname=nesasm
+pkgver=4.b7affbb
+pkgrel=1
+pkgdesc="Linux port of the NESASM3 assembler."
+arch=('x86' 'x86_64')
+url="https://github.com/toastynerd/nesasm"
+license=('Unknown')
+groups=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(${_pkgname}::git+https://github.com/toastynerd/nesasm)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make
+
+ mkdir -p $pkgdir/usr/bin
+ cp bin/nesasm $pkgdir/usr/bin
+}
+
+# vim:set ts=2 sw=2 et: