summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Woelk2016-07-22 15:22:07 -0500
committerMatt Woelk2016-07-22 15:22:07 -0500
commitb9cb9db48ee81041d949c6ce6243dd5addfa0b05 (patch)
tree4c8877c9fc945923431f998f10e33a01e9d49cad /PKGBUILD
parent9b560ce5b577b349bf478549562d0f717aa6f77d (diff)
downloadaur-b9cb9db48ee81041d949c6ce6243dd5addfa0b05.tar.gz
Added .desktop file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e3da7374697..2322e928c925 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,20 +19,22 @@ _gettoken() {
if [[ "$token" == "" ]]; then
echo
- echo "\n==> ERROR: Could not get the download token"
+ echo " -> Could not get the download token, '_retoken' might need an update"
exit 1
fi
- echo $token
+ echo "$token"
}
_token=$(_gettoken)
_pkgurl="https://downloads.nessus.org/nessus3dl.php?file=${_filename}&licence_accept=yes&t=${_token}"
source=("${_filename}::${_pkgurl}"
+ nessus.desktop
nessus.sh
LICENSE)
md5sums=('4106308f11c6b56f05932ee7bf9e71e1'
+ '388578bf980efe6e6d3f33fcc289543a'
'8c5772ac63f97d94475fe03e80d6ba5c'
'1db6df5a39009ace46c7ee40141ece1b')
@@ -52,4 +54,7 @@ package() {
# license
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/nessus/LICENSE"
+
+ # menu entry
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}