summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 18:35:39 +0100
committerBartłomiej Piotrowski2018-01-07 18:35:39 +0100
commit01f794aaad5a33f9417f66663891d60b5c5e5a06 (patch)
tree9d43c2767c87ebd1bf3ce36d92bb1f653f8f37c3 /PKGBUILD
downloadaur-01f794aaad5a33f9417f66663891d60b5c5e5a06.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..426c0919f98c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Tiago Pierezan Camargo <tcamargo@gmail.com>
+# Contributor: robb_force <robb_force@holybuffalo.net>
+
+pkgname=nestopia
+pkgver=1.48
+pkgrel=1
+pkgdesc='An NES emulator featuring cycle exact emulation, a ridiculous number of mappers, and lots of custom sound chips.'
+url='http://0ldsk00l.ca/nestopia/'
+license=('GPL')
+arch=('x86_64')
+depends=('sdl2' 'alsa-lib' 'gtk3' 'glu' 'libarchive' 'libao')
+makedepends=('unzip' 'mesa' 'xdg-utils' 'cmake')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rdanbrook/nestopia/tarball/$pkgver")
+sha256sums=('ee14b9476748669ac1af73116beb2a6e3dd6b41c0b1d2f7149fb8716bb02d749')
+
+build() {
+ cd "$srcdir"/rdanbrook-nestopia-*
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "$srcdir"/rdanbrook-nestopia-*
+ make install DESTDIR="$pkgdir"
+}