summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-02-03 21:21:59 +0100
committerEmiel Wiedijk2018-02-03 21:27:17 +0100
commit7115329ef5e23152cbb06011299579f4951ed3b7 (patch)
tree938a84625d53a19f3576be7f34975c9b001c2cd4 /PKGBUILD
parent01f794aaad5a33f9417f66663891d60b5c5e5a06 (diff)
downloadaur-7115329ef5e23152cbb06011299579f4951ed3b7.tar.gz
Move build system to autotools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 426c0919f98c..6d57f10463b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: aimileus < me at aimileus dot nl >
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Tiago Pierezan Camargo <tcamargo@gmail.com>
# Contributor: robb_force <robb_force@holybuffalo.net>
@@ -11,17 +12,18 @@ url='http://0ldsk00l.ca/nestopia/'
license=('GPL')
arch=('x86_64')
depends=('sdl2' 'alsa-lib' 'gtk3' 'glu' 'libarchive' 'libao')
-makedepends=('unzip' 'mesa' 'xdg-utils' 'cmake')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/rdanbrook/nestopia/tarball/$pkgver")
-sha256sums=('ee14b9476748669ac1af73116beb2a6e3dd6b41c0b1d2f7149fb8716bb02d749')
+makedepends=('unzip' 'mesa' 'xdg-utils' 'cmake' 'git')
+source=("git+https://github.com/rdanbrook/nestopia.git#tag=$pkgver")
+sha256sums=('SKIP')
build() {
- cd "$srcdir"/rdanbrook-nestopia-*
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cd "$pkgname"
+ autoreconf -vif
+ ./configure --prefix=/usr
make
}
package() {
- cd "$srcdir"/rdanbrook-nestopia-*
+ cd "$pkgname"
make install DESTDIR="$pkgdir"
}