summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2023-11-18 20:17:31 +0100
committerCarsten Teibes2023-11-18 20:17:31 +0100
commit9c47d2d61b0bb29eb609bcc0c9b39d091acf660e (patch)
treee6cbdecb22fbb56f9fd47248a767beafb971b19b /PKGBUILD
parentde652c651c540658800efe07b893cc474ef5370b (diff)
downloadaur-9c47d2d61b0bb29eb609bcc0c9b39d091acf660e.tar.gz
[fix] oversight
Thanks @Polizei!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00cf82dc0367..c45be2a58c43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=nestopia
pkgver=1.52.0
-pkgrel=2
+pkgrel=3
pkgdesc='An NES emulator featuring cycle exact emulation, a ridiculous number of mappers, and lots of custom sound chips.'
url='http://0ldsk00l.ca/nestopia/'
license=('GPL')
@@ -15,8 +15,12 @@ sha256sums=('eae1d2f536ae8585edb8d723caf905f4ae65349edee4ffbee45f9f52b5e3b06c')
install=$pkgname.install
prepare() {
+ cd $pkgname-$pkgver
+
+ autoreconf -fi
+
# remove GLU dependency
- sed -i "s/fltk-config.*--ldflags/&|sed 's#-lGLU ##g'/g" $pkgname-$pkgver/configure.ac
+ sed -i "s/fltk-config.*--ldflags/&|sed 's#-lGLU ##g'/g" configure
}
build() {
@@ -25,7 +29,6 @@ build() {
# build system normally disables this warning
export CXXFLAGS="$CXXFLAGS -Wno-narrowing"
- autoreconf -fi
./configure --prefix=/usr
make
}