summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-11-29 00:17:23 +0100
committerBaptiste Jonglez2016-11-29 00:19:40 +0100
commit8e3bb135d0dc090115674448ac0ed28f49dbb751 (patch)
tree1688fe5a887645eee002f0b8a08d0d3405b6690c /PKGBUILD
parent6c775333ac11c7764603fb838c0271ab2ea3aa54 (diff)
downloadaur-8e3bb135d0dc090115674448ac0ed28f49dbb751.tar.gz
net-tools-mptcp: Switch to using a tarball instead of building from a git branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c15f2962f97a..53e3103b0aeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,21 @@
# Adapted from the net-tools package in [core].
pkgname=net-tools-mptcp
_srcname=net-tools
-_mptcpv=0.91
-pkgver=0.91.1.r0.g888d808
+pkgver=0.91.1
pkgrel=1
-epoch=1
+epoch=2
pkgdesc="Configuration tools for Linux networking, with Multipath TCP support"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://multipath-tcp.org/pmwiki.php/Users/Tools"
depends=('glibc')
-makedepends=('git')
provides=('net-tools')
# mptcp-net-tools is the old name of the AUR package
conflicts=('mptcp-net-tools' 'net-tools')
# Build fails with -jX for X > 1. Force sequential build
options=(!makeflags)
-source=("git://github.com/multipath-tcp/net-tools#branch=mptcp_v${_mptcpv}")
-sha1sums=('SKIP')
-
-pkgver() {
- cd "${srcdir}/${_srcname}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("${pkgname}-${pkgver}::https://github.com/multipath-tcp/${_srcname}/archive/v${pkgver}.tar.gz")
+sha256sums=('a04a390a09b90d12e9648c2f4adeb4d0a29c5a3ca00a3d4d2679e95a2dd9cbc4')
prepare() {
cd "${srcdir}/${_srcname}"
@@ -38,7 +31,7 @@ build() {
package() {
cd "${srcdir}/${_srcname}"
- make DESTDIR=${pkgdir}/usr update
+ make DESTDIR="${pkgdir}/usr" update
# the following is provided by yp-tools
rm "${pkgdir}"/usr/bin/{nis,yp}domainname