summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnthony Ruhier2017-01-26 22:05:21 +0100
committerAnthony Ruhier2017-01-26 22:05:21 +0100
commita83816677213d9fc3bd9e4e205c294421ecd39a6 (patch)
treec503c5e3fdcac09d6a3cb2564f599883b5a251d4 /PKGBUILD
parent0ff3ef93b4d5b3a3ca526d6cf80b8fe9405e64d7 (diff)
downloadaur-a83816677213d9fc3bd9e4e205c294421ecd39a6.tar.gz
v1.8.3 and python 3
Netbox is python 3 compatible now!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 23 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ef824a59cc3..d9aad4ba0998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,36 @@
_name=netbox
pkgname=${_name}
-pkgver=1.8.2
+pkgver=1.8.3
pkgrel=1
pkgdesc="IP address management (IPAM) and data center infrastructure management (DCIM) tool."
arch=('any')
url="https://github.com/digitalocean/${_name}"
license=('Apache-2.0')
-depends=('python2'
- 'gunicorn-python2'
+depends=('python'
+ 'gunicorn'
'libffi'
'libpgf'
'openssl'
- 'python2-crypto'
- 'python2-cryptography'
- 'python2-django'
- 'python2-django-debug-toolbar-git'
- 'python2-django-filter'
- 'python2-django-rest-framework'
- 'python2-django-rest-swagger0.3.10'
- 'python2-django-tables2'
- 'python2-graphviz'
- 'python2-lxml'
- 'python2-markdown'
- 'python2-natsort'
- 'python2-ncclient'
- 'python2-netaddr'
- 'python2-paramiko'
- 'python2-py-gfm'
- 'python2-psycopg2'
- 'python2-sqlparse'
- 'python2-xmltodict')
+ 'python-crypto'
+ 'python-cryptography'
+ 'python-django'
+ 'python-django-debug-toolbar-git'
+ 'python-django-filter'
+ 'python-django-rest-framework'
+ 'python-django-rest-swagger0.3.10'
+ 'python-django-tables2'
+ 'python-graphviz'
+ 'python-lxml'
+ 'python-markdown'
+ 'python-natsort'
+ 'python-ncclient'
+ 'python-netaddr'
+ 'python-paramiko'
+ 'python-py-gfm'
+ 'python-psycopg2'
+ 'python-sqlparse'
+ 'python-xmltodict')
conflicts=("${_name}-git")
replaces=("${_name}-git")
@@ -41,7 +41,7 @@ source=("${url}/archive/v${pkgver}.tar.gz"
"${_name}.tmpfile"
"debug_toolbar_middleware.patch"
"gunicorn_config.py")
-sha256sums=('5d54a1e8ca8bbc60cacb4a9fcd6287aa330a3af96a0817555f94bbcb3870cbff'
+sha256sums=('a8ad15f96ae2f606c950f907c46a4a40a546fc0269e6fd40a760efff3f8c4363'
'12bb0253aea3dd763ee8bb1a17064256155b79e904a4350abf89cf4c65235951'
'1028bac96ddcd18c10646dff26027b4891fcab4381436e2b6ea3302887a5586f'
'2d6d55cad836eca187a7dfe40227f994e9b2f565e71fd39e296bc8bb73bf259a'
@@ -52,8 +52,6 @@ prepare() {
cd "${srcdir}/${_name}-${pkgver}"
patch -p0 -i "${srcdir}"/debug_toolbar_middleware.patch
- sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- $(find "${_name}" -name '*.py')
}
package() {