summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgryffyn2020-06-27 15:27:45 +0100
committergryffyn2020-06-27 15:27:45 +0100
commit16b0aed7f991bb624f3d5bd3f1a2bf7e51587f9a (patch)
tree5963daca41e9d925902545d907b568ec744f78c0 /PKGBUILD
downloadaur-16b0aed7f991bb624f3d5bd3f1a2bf7e51587f9a.tar.gz
Created package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0c83e25acd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: gryffyn <aur at evan dot mp>
+
+pkgname=netctl-obfuscate
+pkgver=v0.1.0
+pkgrel=1
+pkgdesc="A tool wrapping wpa_passphrase to convert plaintext keys in netctl config files to a PSK."
+arch=('any')
+url="https://github.com/gryffyn/netctl-obfuscate"
+license=("MIT")
+makedepends=('go' 'git')
+source=("${pkgname}"::"git+https://github.com/gryffyn/${pkgname}#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ mkdir build
+ go build -o build/${pkgname}
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}