summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorchenjunyu192018-04-06 12:46:50 +0800
committerchenjunyu192018-04-06 12:46:50 +0800
commit8a3aee22f7c3fbfb9d103555522906cef107c970 (patch)
treeda2ea18483dfc966325e548931ad9c998d1f3875 /PKGBUILD
downloadaur-8a3aee22f7c3fbfb9d103555522906cef107c970.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b699a84a455b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: chenjunyu19 <chenjunyu19@qq.com>
+
+pkgname=netease-dl-git
+pkgver=r37.84b226f
+pkgrel=1
+pkgdesc=基于命令行的网易云音乐下载器
+arch=('any')
+url="https://github.com/ziwenxie/netease-dl"
+license=('MIT')
+depends=('python' 'python-requests>=2.10.0' 'python-pycryptodomex' 'python-click>=5.1' 'python-prettytable>=0.7.2')
+makedepends=('git' 'python-setuptools')
+options=(!emptydirs)
+source=("git+https://github.com/ziwenxie/netease-dl")
+md5sums=('SKIP')
+_gitname=netease-dl
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file