summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryjun1232020-04-28 08:42:35 +0800
committeryjun1232020-04-28 08:42:35 +0800
commitbb494e39ba6ee9f23837b3a96e1c34582bf9bd8c (patch)
treebb123a699082abb025653289eea68af462cbe1ed /PKGBUILD
downloadaur-bb494e39ba6ee9f23837b3a96e1c34582bf9bd8c.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a76aea078fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: yjun <jerrysteve1101@gmail.com>
+
+pkgname=netease-music-tui
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="netease cloud music terminal client by rust"
+arch=('x86_64')
+url="https://github.com/betta-cyber/netease-music-tui"
+license=('MIT')
+makedepends=('rust')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/betta-cyber/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('53a35bfdc9e69a4cfeb154eb082b7fe7af9a79ac32049a19d6536938d7114597')
+build() {
+ cd ${pkgname}-${pkgver}
+ cargo build --release
+}
+package() {
+ install -Dm755 ${pkgname}-${pkgver}/target/release/ncmt ${pkgdir}/usr/bin/ncmt
+}