summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraxionl2018-12-27 23:07:56 +0900
committeraxionl2018-12-27 23:07:56 +0900
commitbed70434e7122cbc34ca100520faa9edc23ae78c (patch)
treed2664bf49523881afcf1169c74380d92b6bdfb85 /PKGBUILD
parentf8b65144a740eb57855c3086dde5baca9076c846 (diff)
downloadaur-bed70434e7122cbc34ca100520faa9edc23ae78c.tar.gz
[Update] netease-musicbox: remove the useless patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9884202cd72..74aefd7fc58d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
pkgname=netease-musicbox
_gitname=musicbox
pkgver=0.2.5.4
-pkgrel=1
+pkgrel=2
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
-depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future')
+depends=('mpg123' 'python-pycryptodomex' 'python-requests' 'python-future' 'python-requests-cache')
makedepends=('python-setuptools')
optdepends=('aria2: music caching'
'libnotify: notifications'
@@ -20,25 +20,22 @@ conflicts=('netease-musicbox')
install=$pkgname.install
license=('MIT')
-source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/0.2.5.4.tar.gz"
+source=("musicbox-$pkgver.tar.gz::https://github.com/darknessomi/musicbox/archive/${pkgver}.tar.gz"
"LICENSE::https://raw.githubusercontent.com/darknessomi/musicbox/master/LICENSE.txt"
- "0001Replace_pyqt4_to_pyqt5_as_depends.patch"
- "0002Remove_python_requests_cache_as_depends.patch")
+ "0001-Replace_pyqt4_to_pyqt5_as_depends.patch")
sha256sums=('4fdfd9061dfdec181736b56166a11bfe27ae9c4011f9c266b57fdfbca232afa3'
'50efc98142cfffe413d73c87c91f2687dfb774217af923f03dfdc8426c9d9552'
- 'c910c12c5ffe23b3cc582fb718017c8dee5ef4e9dacfb1944f35266a79f8bbee'
- '24b74424cd624742e35631fafd24ad6fd6527807728deeb1cc0a81a1415370b7')
+ '4ce77308982339ef8f90ac34e3d9e0f1b2894d4d36a09a3071919bbc39b6dde5')
prepare() {
- cd "${srcdir}/musicbox-${pkgver}"
- patch -Np1 -i "${srcdir}/0001Replace_pyqt4_to_pyqt5_as_depends.patch"
- patch -Np1 -i "${srcdir}/0002Remove_python_requests_cache_as_depends.patch"
+ cd "${srcdir}/musicbox-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-Replace_pyqt4_to_pyqt5_as_depends.patch"
}
package() {
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}/musicbox-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/musicbox-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4 et: