summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2017-02-21 01:48:51 +0800
committerlilac2017-02-21 01:48:51 +0800
commite2f589021019e297fb4518bb3e18ba22a085e3eb (patch)
treea589abc0821117ac1c5121403d3081948128ac5d /PKGBUILD
parent56b88016a6207e1f518b44c6f6f2624e80d37c44 (diff)
downloadaur-e2f589021019e297fb4518bb3e18ba22a085e3eb.tar.gz
update by lilac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cf03d48dd09..0aeb3cddb248 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,18 @@
pkgname=netease-musicbox-git
_gitname=musicbox
pkgver=r481.c045426
-pkgrel=1
+pkgrel=2
pkgdesc="A sexy command line interface musicbox for NetEase based on Python"
arch=(any)
url="https://github.com/darknessomi/musicbox"
license=('MIT')
-depends=('python' 'mpg123' 'python-beautifulsoup4' 'python-requests' 'python-setuptools' 'python-crypto' 'python-future')
+depends=('python2' 'mpg123' 'python2-beautifulsoup4' 'python2-requests' 'python2-setuptools' 'python2-crypto' 'python2-future')
+optdepends=('aria2: music caching'
+ 'python2-keybinder2: global keybindings'
+ 'libnotify: notifications'
+ 'python2-qt4: lyrics support'
+ 'python2-dbus: lyrics support'
+ )
makedepends=('git')
options=(!emptydirs)
source=("git+https://github.com/darknessomi/musicbox")
@@ -23,7 +29,7 @@ pkgver() {
package() {
cd "$srcdir/$_gitname"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python2 setup.py install --root="$pkgdir/" --optimize=1
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
install -m755 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
}