summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2016-05-10 16:01:24 +0200
committerChristian Hesse2016-05-10 16:01:24 +0200
commit91a68b738ab021822926e92696d2d35a0ba25367 (patch)
tree3f91a44d3ea586c0aea7d7be28317fd54f5bcf65 /PKGBUILD
parent005c194454bd5ee47b801ff3a95912d90f5b4f4c (diff)
downloadaur-91a68b738ab021822926e92696d2d35a0ba25367.tar.gz
commit netlink-notify-git 0.7.4.r2.gb08dc6a-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9e01080bd6e..f656649cda31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=netlink-notify-git
-pkgver=0.6.3.r3.gdde8c75
+pkgver=0.7.4.r2.gb08dc6a
pkgrel=1
pkgdesc="Notify about netlink changes - git checkout"
arch=('i686' 'x86_64')
@@ -11,16 +11,21 @@ makedepends=('git' 'imagemagick' 'markdown')
provides=('netlink-notify')
conflicts=('netlink-notify')
license=('GPL')
-install=netlink-notify.install
source=('git://github.com/eworm-de/netlink-notify.git')
+sha256sums=('SKIP')
pkgver() {
cd netlink-notify/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
fi
}
@@ -36,4 +41,3 @@ package() {
make DESTDIR="${pkgdir}" install
}
-sha256sums=('SKIP')