summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpike292024-04-07 20:57:28 +0200
committerSpike292024-04-07 20:57:28 +0200
commit05b00e81b4601cf0a15888092f058d7f9465f72f (patch)
tree5cd5fa110f5edd5887ec61aa92223c34521726ae /PKGBUILD
parent3a42639f12477373130bfd4bc1b5a89ba1b3dc5a (diff)
downloadaur-05b00e81b4601cf0a15888092f058d7f9465f72f.tar.gz
Disable _GLIBCXX_ASSERTIONS to address a crash
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 715ba165827b..6a2cb272c440 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=netradiant-custom
pkgver=20240309
-pkgrel=1
+pkgrel=2
pkgdesc="The open-source, cross-platform level editor for id Tech based games (NetRadiant fork)"
url="https://garux.github.io/NRC/"
depends=('bash' 'gcc-libs' 'glib2' 'glibc' 'libjpeg-turbo' 'libpng' 'libxml2' 'qt5-base' 'zlib')
@@ -18,6 +18,9 @@ license=('GPL' 'BSD' 'LGPL')
arch=('i686' 'x86_64')
build () {
+ # Work around a crash at startup or when displaying the texture browser
+ export CXXFLAGS+=" -Wp,-U_GLIBCXX_ASSERTIONS"
+
cd "${srcdir}/${pkgname}/"
make
}