summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpike292019-06-19 18:23:00 +0200
committerSpike292019-06-19 18:23:00 +0200
commit7019e28c679f661ba9eff7dc61ace4a9cfbe1424 (patch)
tree7a44cef8aa816f40eb48b89ae0feb5ec94f5cece /PKGBUILD
parent34bf66185f017f50c1478e25f391dde7819a234a (diff)
downloadaur-7019e28c679f661ba9eff7dc61ace4a9cfbe1424.tar.gz
Indentation cleanups
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b134f651ae8d..d5cb6d671b35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,53 +17,53 @@ source=("${pkgname}::git://git.xonotic.org/xonotic/netradiant.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}/"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${pkgname}/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${pkgname}/"
+ cd "${srcdir}/${pkgname}/"
- # Needs Internet; Downloads gamepacks
- # Possible values for the GAMEPACKS_LICENSE_LIST filter are "free",
+ # Needs Internet; Downloads gamepacks
+ # Possible values for the GAMEPACKS_LICENSE_LIST filter are "free",
# "all" (free + proprietary) and "none". To only fetch Xonotic and
# Unvanquished gamepacks for example, use -DGAMEPACKS_LICENSE_LIST=none
# with -DGAMEPACKS_NAME_LIST="Xonotic Unvanquished"
- cmake -G 'Unix Makefiles' -H. -Bbuild \
+ cmake -G 'Unix Makefiles' -H. -Bbuild \
-DCMAKE_BUILD_TYPE=Release \
-DFHS_INSTALL=ON \
-DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
- -DDOWNLOAD_GAMEPACKS=ON \
- -DGAMEPACKS_LICENSE_LIST=free \
- -DGAMEPACKS_NAME_LIST=none
-
- cmake --build build -- -j$(nproc)
+ -DDOWNLOAD_GAMEPACKS=ON \
+ -DGAMEPACKS_LICENSE_LIST=free \
+ -DGAMEPACKS_NAME_LIST=none
+
+ cmake --build build -- -j$(nproc)
# This step is needed again for CMake to detect the gamepacks it has to install
- cmake -H. -Bbuild
+ cmake -H. -Bbuild
}
package() {
- cd "${srcdir}/${pkgname}/"
-
- cmake --build build -- install
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/netradiant/LICENSE"
+ cd "${srcdir}/${pkgname}/"
+
+ cmake --build build -- install
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/netradiant/LICENSE"
# Map mime type doesn't work and produces a pacman warning
- rm -r ${pkgdir}/usr/share/mime/
+ rm -r ${pkgdir}/usr/share/mime/
- # Fix (some of) the included gamepacks so they work with the official
+ # Fix (some of) the included gamepacks so they work with the official
# Archlinux packages. Normally we would do this in prepare(), but this
# is not an viable option, as the Makefile initiates the download and
# update of the gamepacks. So we would need to call the referenced
# download script ourselves in prepare() and modify the Makefile so it
# doesn't try to do it in build() too. Not worth it. Don't forget to
- # comment the lines with the gamepacks that you don't use, otherwise
+ # comment the lines for the gamepacks that you don't use, otherwise
# the sed command will fail.
- sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/nexuiz/"' "${pkgdir}/usr/share/netradiant/games/nexuiz.game"
- sed -i -e '/enginepath_linux/c\ enginepath_linux="/opt/warsow/"' "${pkgdir}/usr/share/netradiant/games/warsow.game"
- sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/xonotic/"' "${pkgdir}/usr/share/netradiant/games/xonotic.game"
+ sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/nexuiz/"' "${pkgdir}/usr/share/netradiant/games/nexuiz.game"
+ sed -i -e '/enginepath_linux/c\ enginepath_linux="/opt/warsow/"' "${pkgdir}/usr/share/netradiant/games/warsow.game"
+ sed -i -e '/enginepath_linux/c\ enginepath_linux="/usr/share/xonotic/"' "${pkgdir}/usr/share/netradiant/games/xonotic.game"
}