summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpike292023-05-04 12:00:30 +0200
committerSpike292023-05-04 12:00:30 +0200
commite652cf5112d6e201789c7a04ec1ff6c4a0ad5188 (patch)
treecf8a447af9cd082005ebad33daaccd3f539ecca7 /PKGBUILD
parent4ee0bfcdaa15b7d5f059b4f3df86e521129fa396 (diff)
downloadaur-e652cf5112d6e201789c7a04ec1ff6c4a0ad5188.tar.gz
Add a patch to fix the compilation with gcc 13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2f24a64220c..32d1ff2f4326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: J0k3r <moebius282 at gmail dot com>
pkgname=netradiant-git
-pkgver=r2274.77fe8cf1
+pkgver=r2536.fa4a5cca
pkgrel=1
epoch=1
pkgdesc='The open source, cross platform level editor for idtech games (GtkRadiant fork)'
@@ -14,8 +14,10 @@ depends=('gtk2' 'gtkglext' 'minizip' 'libjpeg-turbo' 'libwebp')
makedepends=('git' 'svn' 'wget' 'unzip' 'cmake' 'make')
provides=('netradiant' 'q3map2' 'q3data' 'q2map' 'qdata3' 'h2data')
conflicts=('netradiant-custom')
-source=("${pkgname}::git+https://gitlab.com/xonotic/netradiant.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://gitlab.com/xonotic/netradiant.git"
+ "build_with_gcc13.diff")
+sha256sums=('SKIP'
+ 'cc0b3a6e3a8064c4eb1b9153748869c5177d427c0f9a6d5044c9e9e197a7a71f')
pkgver() {
cd "${srcdir}/${pkgname}/"
@@ -23,8 +25,11 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/${pkgname}/"
- # Fetch the Crunch submodule (it is compiled when present)
+ # Fix compilation with gcc 13
+ patch -d ${srcdir}/${pkgname} -p1 < build_with_gcc13.diff
+
+ cd "${srcdir}/${pkgname}"
+ # Fetch the Crunch submodule
git submodule update --init --recursive
}