summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgammy2016-12-20 12:43:48 +0100
committergammy2016-12-20 12:43:48 +0100
commit11f5a2cd28222aba69b43c3bab9e5e19578dd4cf (patch)
treebd4972b37732b175ce56aee78986f61fc69beac6 /PKGBUILD
parentabed6c8a8e4fddb968f9646292dfc08b7f9fff09 (diff)
downloadaur-11f5a2cd28222aba69b43c3bab9e5e19578dd4cf.tar.gz
If available, use git describe to obtain the current version. Update description (made it shorter). Correct source url
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2df3272f3a24..417cc14c552a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Kristian Gunstone <kristian.gunstone.butnotthispart@pean.northis.org>
pkgname=netris-git
pkgver=0.55g # Is automatically updated by pkgver() below
-pkgrel=1
-pkgdesc="Mark H. Weaver's Netris -- A free networked version of Tetris. This is my (the AUR package maintainer) fork, which itself is based on Nathan Aclander's fork."
+pkgrel=2
+pkgdesc="Mark H. Weaver's Netris - A networked terminal version of Tetris. This is my fork, which itself is based on Nathan Aclander's fork."
arch=('i686' 'x86_64')
-url="https://github.com/naclander/netris.git"
+url="https://github.com/gammy/netris.git"
license=('GPL2')
depends=()
makedepends=('git')
@@ -16,7 +16,11 @@ md5sums=('SKIP')
source=("${pkgname}::git+https://github.com/gammy/netris.git")
pkgver() {
- head -n1 "${pkgname}/VERSION" | tr '-' '_'
+ cd "${pkgname}"
+ git fetch > /dev/null 2>&1 \
+ && git describe --tags > /dev/null 2>&1 \
+ && git describe --tags | cut -d '-' -f -2 > VERSION
+ head -n1 VERSION | tr '-' '_'
}
build() {