summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian J. Bronner2019-09-17 21:46:02 +0200
committerSebastian J. Bronner2019-09-17 21:46:02 +0200
commit0c88f78ba3305cbd21878d8147ef6382517fa4c9 (patch)
tree69096f1935b60573f4474b7ca1cf69dfdc21a619 /PKGBUILD
parent23397eea0694335d284f05a7f21e3a72ffe9915c (diff)
downloadaur-0c88f78ba3305cbd21878d8147ef6382517fa4c9.tar.gz
Fix bug in _makedir; add comments indicating source of makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7239355fc09c..6670964626dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=netsurf-fb
pkgver=3.9
-pkgrel=1
+pkgrel=2
pkgdesc='Lightweight and fast web browser'
arch=(x86_64 i686)
url=https://www.netsurf-browser.org/
license=(MIT GPL2)
depends=(curl glibc 'libdom>=0.4.0' libjpeg libnsfb 'libnsutils=0.0.5-4' \
libpng libsvgtiny 'libutf8proc>=2.4.0' libwebp openssl)
-makedepends=(check gcc 'libcss>=0.9.0' 'libnsbmp>=0.1.5' 'libnsgif>=0.2.1' \
- make 'nsgenbind>=0.7' patch words xxd)
+makedepends=(check coreutils gcc gzip 'libcss>=0.9.0' 'libnsbmp>=0.1.5' \
+ 'libnsgif>=0.2.1' make 'nsgenbind>=0.7' patch words xxd)
_download_uri=https://download.netsurf-browser.org/netsurf/releases/source
source=(
$_download_uri/netsurf-$pkgver-src.tar.gz
@@ -20,22 +20,26 @@ sha256sums=(
'd72f1c6f6113a01e541f8476a93c347235068779140090df55ba402eb4a8ecc3'
'1c2bb855e1b778bae1234018fa4b138f974a55ee56fd77ec0a21d3fcca487d38'
)
-_makedir=$pkgname-$pkgver
+_makedir=netsurf-$pkgver
_makeopts="-C $_makedir PREFIX=/usr TARGET=framebuffer"
prepare() {
+ # makedepends: patch
patch --directory=$_makedir --strip=0 < $startdir/utils-idna.patch
}
build() {
+ # makedepends: gcc libcss libnsbmp libnsgif make nsgenbind xxd
make $_makeopts
}
check() {
+ # makedepends: check gcc make words
make $_makeopts test
}
package() {
+ # makedepends: coreutils gzip make
local installopts='--mode 0644 -D --target-directory'
local shrdir="$pkgdir/usr/share"
local licdir="$shrdir/licenses/$pkgname"