summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-05-13 16:03:56 +0800
committerzxp198210052024-05-13 16:03:56 +0800
commitc84d0dd908a58037366365942f6dfbc733bda5bb (patch)
treebb534afb13eeb304de1ffefec7db7c528a590a68 /PKGBUILD
parent19a175874bae417664501ed5dab37bbc181adab6 (diff)
downloadaur-c84d0dd908a58037366365942f6dfbc733bda5bb.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d523d20e276b..a7e589105e45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=newpad-bin
_pkgname=NewPad
pkgver=1.3.0
_electronversion=22
-pkgrel=4
+pkgrel=5
pkgdesc="An OblivionOcean Software, Bro.高颜值、易上手的Markdown记事本"
arch=("x86_64")
url="https://github.com/OblivionOcean/NewPad"
@@ -25,14 +25,15 @@ source=(
)
sha256sums=('cf2934d09001055e05fbf6bcdfdfd355ef6c5ca96f8419da0a2b18f1368f152a'
'5950cbd8232f1a8804591dd285cf0c27a9b5078c2d2d51030972b334664889d4'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@cfgdirname@|${_pkgname}|g" \
-e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -f -n -q --categories="Utility" --name="${_pkgname}" --exec="${pkgname} %U"
+ gendesk -f -n -q --pkgname="${pkgname%-bin}" --categories="Utility" --name="${_pkgname}" --exec="${pkgname} %U"
asar e "${srcdir}/resources/app.asar" "${srcdir}/app.asar.unpacked"
icotool -x "${srcdir}/app.asar.unpacked/logo.ico" -o "${srcdir}/app.asar.unpacked/logo.png"
sed "s|logo.ico|logo.png|g" -i "${srcdir}/app.asar.unpacked/main.js"