summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 19:01:43 +0200
committersl1pkn072015-06-08 19:01:43 +0200
commit71a6fe542a2f847e029e357c818063fe0553ed46 (patch)
treebee0044c7d5d2ff6d4b165e6bb101711131a4960 /PKGBUILD
downloadaur-71a6fe542a2f847e029e357c818063fe0553ed46.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbaae10e119e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Carsten Abele <yonk@yonk.de>
+
+pkgname=newspost
+pkgver=2.1.1
+pkgrel=3
+pkgdesc="A usenet binary autoposter for unix"
+url="http://newspost.unixcab.org/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc')
+source=("http://newspost.unixcab.org/download/${pkgname}-${pkgver}.tar.gz"
+ 'getline.patch')
+sha1sums=('244f31c6e5aa8e41224310295e477ab4a8a17071'
+ 'c64d67627b72fea3bd23d2c81f2dbfbbddbd1fb2')
+
+prepare() {
+ patch -d "${pkgname}-${pkgver}" -Np1 -i ../getline.patch
+}
+
+build() {
+ make -C "${pkgname}-${pkgver}"
+}
+
+package() {
+ make -C "${pkgname}-${pkgver}" PREFIX="${pkgdir}/usr/" MANDIR="${pkgdir}/usr/share/man/man1" install
+} \ No newline at end of file