summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJiří Kuchyňka (Anty)2021-02-10 21:09:55 +0100
committerJiří Kuchyňka (Anty)2021-02-10 21:09:55 +0100
commitd507bb6e7c533d466dbf221a5621f786c3becb5f (patch)
tree4eab2e4b64421bef25d9d304428c06496a95c2c0 /PKGBUILD
downloadaur-d507bb6e7c533d466dbf221a5621f786c3becb5f.tar.gz
initial commit;
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a2378521a08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Anty0 <anty150 at gmail dot com>
+
+pkgdesc='Plugin for Nextcloud to create hashes of files'
+pkgname=('nextcloud-app-checksum')
+_appname='checksum'
+pkgver=1.0.1
+pkgrel=1
+arch=('any')
+license=('GPL3')
+url="https://github.com/westberliner/checksum"
+makedepends=()
+depends=('nextcloud')
+options=('!strip')
+source=("${_appname}-v${pkgver}.tar.gz::${url}/releases/download/${pkgver}/${_appname}.tar.gz")
+sha512sums=('ed25f232e1909b306229c559935281c15af10fafe0d912f1d98ad038da244e48b233d6b98da69d4dbfb690a6c74e33da76d79725dfb409eddf6ca9bace29f17e')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -a "${srcdir}/${_appname}" "${pkgdir}/usr/share/webapps/nextcloud/apps/${_appname}"
+}