summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-11-15 07:24:00 +0700
committerKonstantin Shalygin2018-11-15 07:24:00 +0700
commit1c86cbc65c90c2d9235f1489206b8143c18d70ce (patch)
tree0b092bb57e1f77f2febb35c472e809906776cbca /PKGBUILD
parent6dc96d879153220e026f464ed806c3e2f779eff6 (diff)
downloadaur-1c86cbc65c90c2d9235f1489206b8143c18d70ce.tar.gz
Make kio as opdependency again.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0060a9ef6e01..581cc80f5ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
pkgname='nextcloud-client'
pkgver='2.5.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Nextcloud desktop client'
arch=('i686' 'x86_64')
url='https://nextcloud.com/'
license=('GPL2')
-depends=('qt5-webengine' 'qtkeychain' 'kio')
-makedepends=('extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'doxygen')
+depends=('qt5-webengine' 'qtkeychain')
+makedepends=('extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'doxygen' 'kio')
optdepends=('python2-nautilus: integration with Nautilus'
'nemo-python: integration with Nemo'
+ 'kio: Resource and network access abstraction (KDE)'
'libgnome-keyring: GNOME keyring client')
conflicts=('owncloud-client')
source=("https://github.com/nextcloud/desktop/archive/v${pkgver}.tar.gz")
@@ -26,10 +27,9 @@ build() {
cd "${srcdir}/desktop-${pkgver}/build"
cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname}
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr
make
make doc-man
}