summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael2020-10-01 02:32:04 -0400
committerMichael2020-10-01 02:32:04 -0400
commit17a8dcd98e1a374803ea239584502ce23e94716b (patch)
treed79e4f9582b1c983304d2fc05b1f1848588164a7 /PKGBUILD
parent822bd373f27354b39f9f7fbe01e91e988561386c (diff)
downloadaur-17a8dcd98e1a374803ea239584502ce23e94716b.tar.gz
Revamp PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 25 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 018079cebbfc..5bffb0c644f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,69 +1,53 @@
-# Maintainer: Danilo Kuehn <dk at nogo-software dot de>
-# Git: https://github.com/nogo/archlinux-pkgbuild
-
-# Uncomment, if you want the last release
-#_version=2.3.3
+# Maintainer: Michael Riegert <michael at eowyn net>
+# Contributor: Danilo Kuehn <dk at nogo-software dot de>
pkgname=nextcloud-client-git
_name=${pkgname/\-git/}
-pkgver=2.5.1.r30.g0dcf6c602
+pkgver=3.0.2.ce2dec019
pkgrel=1
pkgdesc="Nextloud client for linux"
arch=('i686' 'x86_64')
url="https://nextcloud.com/"
license=('GPL2')
-depends=('qtkeychain' 'qt5-webkit' 'qt5-webengine' 'hicolor-icon-theme' 'xdg-utils')
+depends=(openssl sqlite qtkeychain qt5-svg qt5-webengine xdg-utils qt5-webkit
+ libcloudproviders qt5-graphicaleffects qt5-quickcontrols2)
+makedepends=(doxygen extra-cmake-modules kio python-sphinx qt5-tools git cmocka)
optdepends=(
- 'python2-nautilus: integration with Nautilus'
- 'nemo-python: integration with Nemo'
+ 'kio: integration with Dolphin'
+ 'nemo-python: integration with Nemo'
+ 'python-nautilus: integration with Nautilus'
+ 'python-caja: integration with Caja'
)
-makedepends=('cmake' 'qt5-tools')
provides=('mirall' 'mirall-git' 'owncloud-client' 'nextcloud-client')
conflicts=('mirall-git' 'owncloud-client' 'owncloud-client-ngs' 'nextcloud-client' 'owncloud-client-git')
-options=(!strip)
backup=('etc/Nextcloud/sync-exclude.lst')
-source=(
- "${_name}::git+https://github.com/nextcloud/desktop.git"
-)
-sha256sums=(
- 'SKIP'
-)
+source=("${_name}::git+https://github.com/nextcloud/desktop.git")
+sha256sums=('SKIP')
pkgver() {
- if [[ -z "${_version}" ]]; then
cd ${srcdir}/${_name}
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
- else
- echo ${_version}
- fi
+ echo $(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/v//g').$(git rev-parse --short HEAD)
}
prepare() {
- cd ${srcdir}/${_name}
- if [[ -n "${_version}" ]]; then
- git checkout "v${_version}"
- fi
- git submodule update --init --recursive
- mkdir -p build
+ cd ${srcdir}/${_name}
+ if [[ -n "${_version}" ]]; then
+ git checkout "v${_version}"
+ fi
+ git submodule update --init --recursive
+ mkdir -p build
}
build() {
- cd ${srcdir}/${_name}/build
-
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ cd ${srcdir}/${_name}/build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE="Release" \
- -DWITH_DOC=FALSE
-
- make
+ -DWITH_DOC=FALSE
+ make
}
package() {
- cd ${srcdir}/${_name}/build
- make DESTDIR=${pkgdir} install
-
- # Fix some naming issues
- if [ -f ${pkgdir}/usr/share/applications/nextcloud.desktop ]; then
- mv ${pkgdir}/usr/share/applications/nextcloud.desktop ${pkgdir}/usr/share/applications/Nextcloud.desktop
- fi
+ cd ${srcdir}/${_name}/build
+ make DESTDIR=${pkgdir} install
}