summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDanilo Kühn2018-07-23 20:43:49 +0200
committerDanilo Kühn2018-07-23 20:43:49 +0200
commit8a02db8887649c7a4c430e1859778b95e4a683e9 (patch)
tree0bcf91ac97e71607cc51ac2e5aa04fad0344dd88 /PKGBUILD
parentc964a622efdd4352e1031e71b2c9b4d3765915fd (diff)
downloadaur-8a02db8887649c7a4c430e1859778b95e4a683e9.tar.gz
update to latest 2.3.3 build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce196e1d6400..e63795c1b657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=nextcloud-client-git
_name=${pkgname/\-git/}
-pkgver=2.3.3.r15.gb095916
-pkgrel=2
+pkgver=2.3.3.r17.g3a48c7c
+pkgrel=1
pkgdesc="Nextloud client for linux"
arch=('i686' 'x86_64')
url="https://nextcloud.com/"
@@ -61,13 +61,16 @@ build() {
make
}
+check() {
+ sed -Ei 's/Icon(\[.*\])?=nextcloud/Icon\1=Nextcloud/g' "${srcdir}/nextcloud-client/build-linux/src/gui/nextcloud.desktop"
+}
+
package() {
cd ${srcdir}/${_name}/build-linux
make DESTDIR=${pkgdir} install
# Fix some naming issues
if [ -f ${pkgdir}/usr/share/applications/nextcloud.desktop ]; then
- sed -Ei 's/Icon(\[.*\])?=nextcloud/Icon\1=Nextcloud/g' ${pkgdir}/usr/share/applications/nextcloud.desktop
mv ${pkgdir}/usr/share/applications/nextcloud.desktop ${pkgdir}/usr/share/applications/Nextcloud.desktop
fi
}