summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Heinrich2017-11-19 13:23:48 +0100
committerJonas Heinrich2017-11-19 13:23:48 +0100
commit3421f25c39efc710e464fa58412dc0587ea4d34c (patch)
tree4eea769f59433c24a6cdb8c3fb4eb4cbe63407f2 /PKGBUILD
parent608e09493ee411080d615818cdae4ea4587fac90 (diff)
downloadaur-3421f25c39efc710e464fa58412dc0587ea4d34c.tar.gz
fixed packaging bug
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eda4982920de..8a307a5d08df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=nextcloud-git
_pkgname=nextcloud
-pkgver=v13.0.0beta1.r42.gdd5373795f
+pkgver=13.0.0beta1.r42.gdd5373795f
pkgrel=1
pkgdesc="A cloud server to store your files centrally on a hardware controlled by you"
arch=('any')
@@ -38,7 +38,7 @@ sha256sums=('SKIP'
pkgver() {
cd "server"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
package() {
@@ -62,5 +62,7 @@ package() {
chmod a+x "$pkgdir"/usr/share/webapps/${_pkgname}/occ
+ rm -r "${pkgdir}/usr/share/webapps/${_pkgname}/tests"
+
# install -Dm0644 "$srcdir"/nextcloud.hook "$pkgdir"/usr/share/libalpm/hooks/nextcloud.hook
}