summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraki-nyan2022-02-19 09:04:24 +0100
committeraki-nyan2022-02-19 09:04:24 +0100
commitec5509da633f547ff65c73aac7199e506f63a15c (patch)
tree37c48d4a4ad68d47fb5e0a489e49de1f070f3af3 /PKGBUILD
parentd449b9b3b2780f2435b425165a34e09d1f812313 (diff)
downloadaur-ec5509da633f547ff65c73aac7199e506f63a15c.tar.gz
Bumped nextpnr-generic Version to 20220219_347ba3a
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84c94bb2adee..fa48f2200fe2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Aki-nyan <aur@catgirl.link>
pkgname=nextpnr-generic-nightly
-pkgver=fd2d4a8f_20211125
+pkgver=20220219_347ba3a
pkgrel=1
epoch=1
pkgdesc="nextpnr portable FPGA place and route tool - generic"
-arch=("any")
+arch=("x86_64")
url="https://github.com/YosysHQ/nextpnr"
license=("custom:ISC")
groups=()
@@ -23,7 +23,7 @@ conflicts=(
)
replaces=()
source=(
- "nextpnr::git+https://github.com/YosysHQ/nextpnr.git"#commit=fd2d4a8f
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=347ba3a"
)
sha256sums=(
"SKIP"
@@ -33,7 +33,6 @@ _PREFIX="/usr"
prepare() {
cd "${srcdir}/nextpnr"
[ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
- cd ..
}
build() {
@@ -47,14 +46,16 @@ build() {
-DCMAKE_INSTALL_PREFIX=${_PREFIX} \
-DUSE_OPENMP=ON \
..
- cd ..
- ninja -C build-generic
- cd ..
+ ninja
+}
+
+check() {
+ cd "${srcdir}/nextpnr"
+ ninja -C build-generic test
}
package() {
cd "${srcdir}/nextpnr"
DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-generic/COPYING"
- cd ..
}