summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpappy2020-09-22 08:38:50 +0200
committerpappy2020-09-22 12:30:55 +0200
commit130a5bb934f92e02d74c5272e3e61c507653c941 (patch)
tree83d9daff1515e8e511c2d9edbf636a9b998fa3be /PKGBUILD
parent9073e7cb2c7d39e5549ce5b80e56bde2e7fb5226 (diff)
downloadaur-130a5bb934f92e02d74c5272e3e61c507653c941.tar.gz
2.14.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD83
1 files changed, 48 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 421ca6fb50ca..9798dff3319b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,72 @@
# Maintainer: PAPPY <pappy _AT_ a s c e l i o n _DOT_ com>
-_version=2.14.13
+_version=2.14.18
_patch=01
+# wrapper version
+_wersion=3.5.43
+
pkgname=nexus
-pkgver=${_version}.${_patch}
-pkgrel=2
+pkgver=$_version.$_patch
+pkgrel=1
pkgdesc="Nexus 2 Repository Manager (OSS)"
url="http://nexus.sonatype.org"
arch=('any')
license=('GPL3')
-depends=('java-environment')
-optdepends=('apache: a full featured webserver'
- 'maven: a java project management and project comprehension tool')
-
+depends=('java-environment=8')
install=nexus.install
-backup=(opt/nexus/bin/jsw/conf/wrapper.conf)
+backup=(usr/lib/nexus/conf/nexus.properties)
conflicts=(nexus2 nexus3 nexus-oss)
provides=(nexus2 nexus)
options=(!strip !docs)
-source=("http://www.sonatype.org/downloads/nexus-$_version-$_patch-bundle.tar.gz"
- 'http://wrapper.tanukisoftware.com/download/3.5.26/wrapper-delta-pack-3.5.26.tar.gz'
- 'nexus'
- 'nexus.service')
-
-sha256sums=('66e2ae803af26c6af34a82cc510d7fa2037080f35a72b4398f65d2f157fd3afc'
- '635e545fde9c8728e4d7126859cab286637d565f041ce63596f5361fb85fc924'
- '945e2fa64d6096416edd60c2a98c0ed385aee00f6bb3b33f6cbbc428b6b47d07'
- 'b89aaee6f035d7be20af5b738ed3b892df7f4db6538f9b7ec3c3f54685bbe7f8')
+source=("https://www.sonatype.org/downloads/nexus-$_version-$_patch-bundle.tar.gz"
+ "https://wrapper.tanukisoftware.com/download/$_wersion/wrapper-delta-pack-$_wersion.tar.gz"
+ nexus.sysusers
+ nexus.tmpfiles
+ nexus.service
+ 01-paths.patch
+ )
-package() {
- cd ${srcdir}
+sha256sums=('350af8b270bec7fda5861a15b8a5b7870fd8903d0b9a210754113d5a966ce6a6'
+ 'eb25cd3a4d63e1540daf37f90820ce48befe673071fcf2ba37f3773654498de1'
+ '9a5908103137af8176664ddb17d166183aa19cd455746d08f0f58a1a3d9f4eb2'
+ 'e4110396c5c2c617f6bc37bbd3cf4c6fa9da72df7df6d035117dea39f3e24ac9'
+ 'a62d439d727c1eced9341ad5fedbc1a5a42494925b01c559e6426c46bbf55c25'
+ '9136aee79732184e1da6cfeca0a77708d0595a35b2e38b16cf28a1b41ae7429d')
- # Create directories
- install -d $pkgdir/opt/nexus
-
+prepare()
+{
+ cd $srcdir/nexus-$_version-$_patch
- # move documentation to the right location
- mkdir -p $pkgdir/usr/share/doc/nexus
- install $srcdir/nexus-$_version-$_patch/*.txt $pkgdir/usr/share/doc/nexus
- rm $srcdir/nexus-$_version-$_patch/*.txt
+ for s in ${source[@]}; do
+ case $s in
+ *.patch)
+ echo -n Applying patch $s...
+ patch -s -p1 -i $srcdir/$s
+ echo ' done'
+ ;;
+ esac
+ done
+}
- # move example configuration to the right location
- mkdir -p $pkgdir/usr/share/doc/nexus/conf
+package()
+{
+ cd $srcdir/nexus-$_version-$_patch
- mkdir -p $pkgdir/opt/sonatype-work
- mkdir -p $pkgdir/opt/nexus/run
+ install -dm755 $pkgdir/usr/lib
+ install -dm755 $pkgdir/usr/share/doc/nexus
+ cp -r . $pkgdir/usr/lib/nexus
- # copy the source to the final directory
- cp -a $srcdir/nexus-$_version-${_patch}/* $pkgdir/opt/nexus || return 1
- install $srcdir/nexus $pkgdir/opt/nexus/bin/nexus
+ rm -rf $pkgdir/usr/lib/nexus/{tmp,logs,bin/nexus.bat}
- #install $srcdir/nexus.properties $pkgdir/opt/nexus/conf/nexus.properties || return 1
+ # move documentation to the right location
+ mv $pkgdir/usr/lib/nexus/*.txt $pkgdir/usr/share/doc/nexus
- install -Dm644 "${srcdir}/nexus.service" "${pkgdir}/usr/lib/systemd/system/nexus.service"
+ #install $srcdir/nexus.properties $pkgdir/opt/nexus/conf/nexus.properties || return 1
+ install -Dm644 $srcdir/nexus.service $pkgdir/usr/lib/systemd/system/nexus.service
+ install -Dm644 $srcdir/nexus.sysusers $pkgdir/usr/lib/sysusers.d/nexus.conf
+ install -Dm644 $srcdir/nexus.tmpfiles $pkgdir/usr/lib/tmpfiles.d/nexus.conf
}
+