summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartina Pietruschka2015-06-08 23:23:44 +0000
committerMartina Pietruschka2015-06-08 23:23:44 +0000
commit5fc925ad9269a5ef8582bafdb376a6f950317cbd (patch)
treedb1cb9417a85ed4c569ecbfecbc17405f6220512 /PKGBUILD
parent4d2b1a48f3b87e8e69d7e45a5c4368ed9899d7f8 (diff)
downloadaur-5fc925ad9269a5ef8582bafdb376a6f950317cbd.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dadb88d991d3..2b93490fbef1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,8 @@ patchver=01
pkgrel=1
pkgdesc="A Maven Repository Manager. Nexus 2"
url="http://nexus.sonatype.org"
-arch=('armv6h'
- 'armv7h'
- 'i686'
+arch=('armv7h'
+ 'i686'
'x86_64')
license=('GPL3')
depends=('java-environment')
@@ -18,25 +17,27 @@ optdepends=('apache: a full featured webserver'
install=nexus.install
backup=(opt/nexus/bin/jsw/conf/wrapper.conf)
-conflicts=( 'nexus2')
-provides=('java-nexus')
+conflicts=('nexus2')
+provides=('java-nexus'
+ 'nexus')
options=(!strip !docs)
source=("http://www.sonatype.org/downloads/nexus-${pkgver}-${patchver}-bundle.tar.gz"
- 'http://wrapper.tanukisoftware.com/download/3.5.26/wrapper-delta-pack-3.5.26.tar.gz'
+ 'http://wrapper.tanukisoftware.com/download/3.5.26/wrapper-delta-pack-3.5.26.tar.gz'
'nexus'
- 'nexus.service')
+ 'nexus.service')
md5sums=('faa9eb422ae52a9beafef87673da1965'
'8c1e180aba2b3991bcf107e899a96cbd'
'fee6289e0ee48ee5705da54660f7595d'
'ac7c0c60bb3c77ff67965ec160ef2517')
-package() {
+build() {
cd ${srcdir}
# Create directories
install -d $pkgdir/opt/nexus
+
# move documentation to the right location
mkdir -p $pkgdir/usr/share/doc/nexus
@@ -57,4 +58,4 @@ package() {
install -Dm644 "${srcdir}/nexus.service" "${pkgdir}/usr/lib/systemd/system/nexus.service"
-} \ No newline at end of file
+}