summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2018-09-16 20:25:11 +0200
committerSefa Eyeoglu2018-09-16 20:25:11 +0200
commit1432e200315d3de21d469d445e50fe125405d0bd (patch)
tree76a95e2a2922b5b645250639debb40ce65a05272 /PKGBUILD
downloadaur-1432e200315d3de21d469d445e50fe125405d0bd.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58d0156262ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=nfancurve
+pkgname=${_pkgname}-git
+pkgver=v016.r12.gea6fcf8
+pkgrel=1
+pkgdesc="A small and lightweight Bash script for using a custom fan curve in Linux for NVIDIA GPUs"
+arch=("any")
+
+url="https://github.com/nan0s7/nfancurve"
+license=("GPL3")
+
+depends=("bash" "nvidia" "nvidia-settings" "procps")
+makedepends=("git")
+conflicts=("${_pkgname}-git")
+
+install=${_pkgname}.install
+
+source=(
+ "${_pkgname}::git+https://github.com/nan0s7/${_pkgname}.git"
+)
+sha512sums=(
+ "SKIP"
+)
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_pkgname}"
+
+ install -m755 -D "temp.sh" "$pkgdir/usr/bin/nfancurve"
+ install -m644 -D "config" "$pkgdir/usr/share/doc/${_pkgname}/config.example"
+}