summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoricebal2018-11-16 08:13:17 -0600
committericebal2018-11-16 08:13:17 -0600
commit19e834af6296986ff78a44f7aa19b0cf13a5e19d (patch)
treebaf1acf3fea57f0a3ee9c69bb79cdfb101332697 /PKGBUILD
parentc55b2c5d60146d384096fbcd91ce81c3def1ab5c (diff)
downloadaur-19e834af6296986ff78a44f7aa19b0cf13a5e19d.tar.gz
fixed DBUS support, and updated CMAKE flags to align with upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ae408e769ab..c7abcda0bf7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ prepare() {
build() {
cd "${pkgname}"
- cmake src/ -DUSE_9P=ON -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=/usr/lib
+ cmake src/ -DUSE_9P=ON -DCMAKE_BUILD_TYPE=Maintainer -DBUILD_CONFIG=everything -DLIB_INSTALL_DIR=/usr/lib
make
}
@@ -37,8 +37,11 @@ package() {
mv "$pkgdir"/var/run "$pkgdir"/run
rmdir "$pkgdir"/var
install -d "$pkgdir"/usr/lib/systemd/system "$pkgdir"/etc/sysconfig "$pkgdir"/usr/libexec/ganesha
+ install src/scripts/ganeshactl/org.ganesha.nfsd.conf "$pkgdir"/etc/dbus-1/system.d/
install src/scripts/systemd/nfs-ganesha.service.el7 "$pkgdir"/usr/lib/systemd/system/nfs-ganesha.service
install src/scripts/systemd/nfs-ganesha-config.service-in.cmake "$pkgdir"/usr/lib/systemd/system/nfs-ganesha-config.service
+ install src/scripts/systemd/nfs-ganesha-lock.service.el7 "$pkgdir"/usr/lib/systemd/system/nfs-ganesha-lock.service
install src/scripts/systemd/sysconfig/nfs-ganesha "$pkgdir"/etc/sysconfig/ganesha
+ install src/scripts/systemd/tmpfiles.d/ganesha.conf "$pkgdir"/etc/tmpfiles.d/ganesha.conf
install src/scripts/nfs-ganesha-config.sh "$pkgdir"/usr/libexec/ganesha
}