summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-09-21 15:50:01 +0800
committerzxp198210052023-09-21 15:50:01 +0800
commit062960473c42825457620a626ccd3f0d8ff532e4 (patch)
treea338f1c6ae35f43b45aa75c3ad0c505d8b207bbe /PKGBUILD
parent28cd4ac40f4bf72765b9a84ecb606efea155a6eb (diff)
downloadaur-062960473c42825457620a626ccd3f0d8ff532e4.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d37dc0634076..c36c08a709c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=nft-viewer-bin
-_appname=nft_viewer
+_pkgname=nft_viewer
+_appname="Bitshares NFT Viewer"
pkgver=1.9.2
-pkgrel=1
+pkgrel=2
pkgdesc="An NFT viewer for the Bitshares blockchain network"
arch=('x86_64')
url="https://github.com/BTS-CM/NFT_Viewer"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('cairo' 'libxrandr' 'libxcomposite' 'glib2' 'expat' 'dbus' 'hicolor-icon-theme' 'libxkbcommon' 'mesa' 'gcc-libs' 'at-spi2-core' \
+depends=('cairo' 'libxrandr' 'libxcomposite' 'glib2' 'expat' 'dbus' 'libxkbcommon' 'mesa' 'gcc-libs' 'at-spi2-core' \
'libx11' 'gtk3' 'libxcb' 'glibc' 'libcups' 'pango' 'nspr' 'nss' 'libxdamage' 'libdrm' 'libxfixes' 'libxext' 'alsa-lib')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_appname}.deb"
- "LICENSE::https://raw.githubusercontent.com/BTS-CM/NFT_Viewer/main/LICENSE")
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}.deb"
+ "LICENSE::https://raw.githubusercontent.com/BTS-CM/NFT_Viewer/v${pkgver}/LICENSE")
sha256sums=('3f0317a8caded555eddeed393a4f3c27f94ca504226c21a448b9cfd6d2ecb255'
'48ecd55adc52c7a1ad9e3f699b9e2348bca9bb6797ce8ad4e9cbe38f7aa11c8a')
+build() {
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ sed "s|\"/opt/${_appname}/${_pkgname}\"|${pkgname%-bin}|g;s|=${_pkgname}|=${pkgname%-bin}|g" \
+ -i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+}
package() {
- bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
+ cp -r "${srcdir}/opt/${_appname}/"* "${pkgdir}/opt/${pkgname%-bin}"
+ ln -sf "/opt/${pkgname%-bin}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/usr/share/applications/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/0x0/apps/${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file