summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2015-06-08 17:25:38 +0800
committerAllen Zhong2015-06-08 17:25:38 +0800
commit320352763b9b230b087b84775cd2793d6d63c1c6 (patch)
treec82f7ec322fd33810723239bca84ea2e800f909e /PKGBUILD
downloadaur-320352763b9b230b087b84775cd2793d6d63c1c6.tar.gz
migrate from aur3: nginx-accesskey 1.6.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD117
1 files changed, 117 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..562e66c13a87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,117 @@
+# $Id$
+# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Sébastien Luttringer
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Miroslaw Szot <mss@czlug.icis.pcz.pl>
+
+_ngx_acc_rev=2.0.3
+
+pkgname=nginx-accesskey
+_pkgname=nginx
+pkgver=1.6.2
+pkgrel=1
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, with ngx_http_accesskey_module.'
+arch=('i686' 'x86_64')
+url='http://nginx.org'
+license=('custom')
+depends=('pcre' 'zlib' 'openssl')
+makedepends=('hardening-wrapper')
+backup=('etc/nginx/fastcgi.conf'
+ 'etc/nginx/fastcgi_params'
+ 'etc/nginx/koi-win'
+ 'etc/nginx/koi-utf'
+ 'etc/nginx/mime.types'
+ 'etc/nginx/nginx.conf'
+ 'etc/nginx/scgi_params'
+ 'etc/nginx/uwsgi_params'
+ 'etc/nginx/win-utf'
+ 'etc/logrotate.d/nginx')
+install=nginx.install
+source=($url/download/nginx-$pkgver.tar.gz
+ http://wiki.nginx.org/images/5/51/Nginx-accesskey-$_ngx_acc_rev.tar.gz
+ service
+ logrotate)
+sha256sums=('b5608c2959d3e7ad09b20fc8f9e5bd4bc87b3bc8ba5936a513c04ed8f1391a18'
+ 'd9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1'
+ '4ecbc33ce4bf2965996f51b0c7edb677904ba5cff9a32e93e1487a428d3a751b'
+ '8700222687c1848f7669faaa23708adc92d6634de156b8935b5b9a9b062ce6e9')
+
+build() {
+ cd "$srcdir"
+ tar zxvf Nginx-accesskey-$_ngx_acc_rev.tar.gz
+
+ cd "$srcdir"/$_pkgname-$pkgver
+
+ ./configure \
+ --prefix=/etc/nginx \
+ --conf-path=/etc/nginx/nginx.conf \
+ --sbin-path=/usr/bin/nginx \
+ --pid-path=/run/nginx.pid \
+ --lock-path=/run/lock/nginx.lock \
+ --user=http \
+ --group=http \
+ --http-log-path=/var/log/nginx/access.log \
+ --error-log-path=stderr \
+ --http-client-body-temp-path=/var/lib/nginx/client-body \
+ --http-proxy-temp-path=/var/lib/nginx/proxy \
+ --http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
+ --http-scgi-temp-path=/var/lib/nginx/scgi \
+ --http-uwsgi-temp-path=/var/lib/nginx/uwsgi \
+ --with-imap \
+ --with-imap_ssl_module \
+ --with-ipv6 \
+ --with-pcre-jit \
+ --with-file-aio \
+ --with-http_dav_module \
+ --with-http_gunzip_module \
+ --with-http_gzip_static_module \
+ --with-http_realip_module \
+ --with-http_spdy_module \
+ --with-http_ssl_module \
+ --with-http_stub_status_module \
+ --with-http_addition_module \
+ --with-http_degradation_module \
+ --with-http_flv_module \
+ --with-http_mp4_module \
+ --with-http_secure_link_module \
+ --with-http_sub_module \
+ --add-module="$srcdir"/nginx-accesskey-$_ngx_acc_rev
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 contrib/vim/ftdetect/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/ftdetect/nginx.vim
+ install -Dm644 contrib/vim/syntax/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/syntax/nginx.vim
+ install -Dm644 contrib/vim/indent/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/indent/nginx.vim
+
+ sed -e 's|\<user\s\+\w\+;|user html;|g' \
+ -e '44s|html|/usr/share/nginx/html|' \
+ -e '54s|html|/usr/share/nginx/html|' \
+ -i "$pkgdir"/etc/nginx/nginx.conf
+ rm "$pkgdir"/etc/nginx/*.default
+
+ install -d "$pkgdir"/var/lib/nginx
+ install -dm700 "$pkgdir"/var/lib/nginx/proxy
+
+ chmod 750 "$pkgdir"/var/log/nginx
+ chown http:log "$pkgdir"/var/log/nginx
+
+ install -d "$pkgdir"/usr/share/nginx
+ mv "$pkgdir"/etc/nginx/html/ "$pkgdir"/usr/share/nginx
+
+ install -Dm644 "$srcdir"/logrotate "$pkgdir"/etc/logrotate.d/nginx
+ install -Dm644 "$srcdir"/service "$pkgdir"/usr/lib/systemd/system/nginx.service
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ rmdir "$pkgdir"/run
+
+ install -d "$pkgdir"/usr/share/man/man8/
+ gzip -9c man/nginx.8 > "$pkgdir"/usr/share/man/man8/nginx.8.gz
+}
+