summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaMeHb-UA2019-10-20 01:06:45 +0300
committerKaMeHb-UA2019-10-20 01:06:45 +0300
commitf1b8e899f148320a38c690886df226cefe9347df (patch)
tree79d757e371f60a3df73cd3f93a9c5201bb88913a /PKGBUILD
downloadaur-f1b8e899f148320a38c690886df226cefe9347df.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..673433ac9835
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=nginx-http3
+pkgver=1.16
+pkgrel=1
+provides=('nginx')
+conflicts=('nginx' 'nginx-unstable' 'nginx-svn' 'nginx-devel' 'nginx-custom-dev' 'nginx-full' 'nginx-libressl')
+pkgdesc="Nginx with Cloudflare's http3 path on the top of quiche"
+arch=('any')
+makedepends=('git' 'cmake' 'make' 'gcc' 'go' 'perl' 'ninja' 'rust')
+depends=()
+url="https://github.com/cloudflare/quiche/tree/master/extras/nginx"
+license=('GPL3')
+source=(
+ "https://nginx.org/download/nginx-$pkgver.$pkgrel.tar.gz"
+ 'git+https://github.com/cloudflare/quiche.git'
+)
+sha256sums=(
+ 'f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b'
+ 'SKIP'
+)
+
+package() {
+ tar xzvf nginx-$pkgver.$pkgrel.tar.gz
+ cd quiche
+ git submodule update --init --recursive
+ cd ../nginx-$pkgver.$pkgrel
+ patch -p01 < ../quiche/extras/nginx/nginx-$pkgver.patch
+ ./configure \
+ --prefix=/etc/nginx \
+ --with-http_ssl_module \
+ --with-http_v2_module \
+ --with-http_v3_module \
+ --with-openssl=../quiche/deps/boringssl \
+ --with-quiche=../quiche
+ make
+ make DESTDIR="$pkgdir/" install
+ cd "$pkgdir/"
+ mkdir usr
+ mv etc/nginx/sbin usr/
+}