summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHoàng Đức Hiếu2017-05-23 09:20:38 +0700
committerHoàng Đức Hiếu2017-05-23 09:20:38 +0700
commit11bf8d3fc0c7cc49eb14ec9504d0d56995cd5497 (patch)
treee62359f732a83162b2b54c7ef8b4a01cfea15d96 /PKGBUILD
downloadaur-11bf8d3fc0c7cc49eb14ec9504d0d56995cd5497.tar.gz
create package for version 0.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9b715a97503
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: hdhoang <arch@hdhoang.space>
+
+pkgname=nginx-mainline-mod-fancyindex
+pkgver=0.4.1
+pkgrel=1
+
+_modname="${pkgname#nginx-mainline-mod-}"
+_nginxver=1.13.0
+
+pkgdesc='Fancy indexes module for the Nginx web server'
+arch=('i686' 'x86_64' 'armv7h')
+depends=('nginx-mainline')
+url="https://github.com/aperezdc/ngx-fancyindex"
+license=('BSD')
+
+source=(
+ http://nginx.org/download/nginx-$_nginxver.tar.gz
+ https://github.com/aperezdc/ngx-$_modname/archive/v$pkgver.tar.gz
+)
+sha256sums=('79f52ab6550f854e14439369808105b5780079769d7b8db3856be03c683605d7'
+ '2b00d8e0ad2a67152a9cee7b7ee67990c742d501412df912baaf1eee9bb6dc71')
+
+prepare() {
+ cd ngx-$_modname-$pkgver
+}
+
+build() {
+ cd "$srcdir"/nginx-$_nginxver
+ ./configure $(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's@^[^:]+: @@') --add-dynamic-module=../ngx-$_modname-$pkgver
+ make modules
+}
+
+package() {
+ install -Dm644 "$srcdir/"ngx-$_modname-$pkgver/LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$srcdir"/nginx-$_nginxver/objs
+ for mod in *.so; do
+ install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
+ done
+}