summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrern2021-09-03 07:29:04 +0000
committerrern2021-09-03 07:29:04 +0000
commitf5d01a4bdf780a976789b3586466533a25bf51d9 (patch)
treea77586229312e3bdae86dc9fa5821ea1afd5b6d4 /PKGBUILD
downloadaur-f5d01a4bdf780a976789b3586466533a25bf51d9.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD149
1 files changed, 149 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd9cb723ac05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,149 @@
+# Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Sébastien Luttringer
+# Contributor: Drew DeVault
+
+_pkgbase=nginx
+pkgbase=nginx-mainline
+pkgname=nginx-mainline-pushstream
+pkgver=1.21.2
+pushstreamver=0.5.4
+pkgrel=1
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, mainline release'
+arch=(x86_64 arm armv6h armv7h aarch64)
+url='https://nginx.org'
+license=('custom')
+depends=('pcre' 'zlib' 'openssl' 'geoip' 'mailcap' 'libxcrypt')
+backup=('etc/nginx/fastcgi.conf'
+ 'etc/nginx/fastcgi_params'
+ 'etc/nginx/koi-win'
+ 'etc/nginx/koi-utf'
+ 'etc/nginx/nginx.conf'
+ 'etc/nginx/scgi_params'
+ 'etc/nginx/uwsgi_params'
+ 'etc/nginx/win-utf'
+ 'etc/logrotate.d/nginx')
+source=($url/download/nginx-$pkgver.tar.gz
+ service
+ logrotate
+ https://github.com/wandenberg/nginx-push-stream-module/archive/$pushstreamver.tar.gz)
+validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8') # Maxim Dounin <mdounin@mdounin.ru>
+md5sums=('6bdec44eea61677e6ab4f8c3554ba039'
+ 'ba2e3b08ce0f0fff7cced624d0ecf7cc'
+ '6a01fb17af86f03707c8ae60f98a2dc2'
+ '9801fc18364c57290e6533ea6192019a')
+sha512sums=('5fa9c8f3a1bd9366b30de2bdbbd5baef47381e6d8672341ed601116baeb077ea1b596716ca06ec03d8a2773a437b78acd408084e49ba239f74de915f1b7fb8a5'
+ 'be2858613d9cca85d80e7b894e9d5fa7892cbddd7a677d2d2f68f419d75fdc1f6802de8014f43ce063b116afd4ff17369873a6adea2dd58ac6f94e617de66fec'
+ '9232342c0914575ce438c5a8ee7e1c25b0befb457a2934e9cb77d1fe9a103634ea403b57bc0ef0cd6cf72248aee5e5584282cea611bc79198aeac9a65d8df5d7'
+ '467ae49409adb675979ff591f98df8c96d71ab5ebc2ef9b3c9430e38e7e84d311b4a98c2b1cb1886d895735223dd2a43370aab61b57b34adb1427c184e6b8c86')
+
+_common_flags=(
+ --with-compat
+ --with-debug
+ --with-file-aio
+ --with-http_addition_module
+ --with-http_auth_request_module
+ --with-http_dav_module
+ --with-http_degradation_module
+ --with-http_flv_module
+ --with-http_geoip_module
+ --with-http_gunzip_module
+ --with-http_gzip_static_module
+ --with-http_mp4_module
+ --with-http_realip_module
+ --with-http_secure_link_module
+ --with-http_slice_module
+ --with-http_ssl_module
+ --with-http_stub_status_module
+ --with-http_sub_module
+ --with-http_v2_module
+ --with-mail
+ --with-mail_ssl_module
+ --with-pcre-jit
+ --with-stream
+ --with-stream_geoip_module
+ --with-stream_realip_module
+ --with-stream_ssl_module
+ --with-stream_ssl_preread_module
+ --with-threads
+ --add-module=/home/alarm/nginx/src/nginx-push-stream-module-$pushstreamver
+)
+
+_mainline_flags=(
+)
+
+prepare() {
+ cp -r $_pkgbase-$pkgver{,-src}
+}
+
+build() {
+ cd $_pkgbase-$pkgver
+ ./configure \
+ --prefix=/etc/nginx \
+ --conf-path=/etc/nginx/nginx.conf \
+ --sbin-path=/usr/bin/nginx \
+ --pid-path=/run/nginx.pid \
+ --lock-path=/run/lock/nginx.lock \
+ --user=http \
+ --group=http \
+ --http-log-path=/var/log/nginx/access.log \
+ --error-log-path=stderr \
+ --http-client-body-temp-path=/var/lib/nginx/client-body \
+ --http-proxy-temp-path=/var/lib/nginx/proxy \
+ --http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
+ --http-scgi-temp-path=/var/lib/nginx/scgi \
+ --http-uwsgi-temp-path=/var/lib/nginx/uwsgi \
+ --with-cc-opt="$CFLAGS $CPPFLAGS" \
+ --with-ld-opt="$LDFLAGS" \
+ ${_common_flags[@]} \
+ ${_mainline_flags[@]}
+
+ make
+}
+
+package_nginx-mainline-pushstream() {
+ provides=($_pkgbase)
+ conflicts=($_pkgbase)
+
+ cd $_pkgbase-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ sed -e 's|\<user\s\+\w\+;|user http;|g' \
+ -e '44s|html|/usr/share/nginx/html|' \
+ -e '54s|html|/usr/share/nginx/html|' \
+ -i "$pkgdir"/etc/nginx/nginx.conf
+
+ rm "$pkgdir"/etc/nginx/*.default
+ rm "$pkgdir"/etc/nginx/mime.types # in mailcap
+
+ install -d "$pkgdir"/var/lib/nginx
+ install -dm700 "$pkgdir"/var/lib/nginx/proxy
+
+ chmod 755 "$pkgdir"/var/log/nginx
+ chown root:root "$pkgdir"/var/log/nginx
+
+ install -d "$pkgdir"/usr/share/nginx
+ mv "$pkgdir"/etc/nginx/html/ "$pkgdir"/usr/share/nginx
+
+ install -Dm644 ../logrotate "$pkgdir"/etc/logrotate.d/nginx
+ install -Dm644 ../service "$pkgdir"/usr/lib/systemd/system/nginx.service
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgbase/LICENSE
+
+ rmdir "$pkgdir"/run
+
+ install -d "$pkgdir"/usr/share/man/man8/
+ gzip -9c man/nginx.8 > "$pkgdir"/usr/share/man/man8/nginx.8.gz
+
+ for i in ftdetect ftplugin indent syntax; do
+ install -Dm644 contrib/vim/$i/nginx.vim \
+ "$pkgdir/usr/share/vim/vimfiles/$i/nginx.vim"
+ done
+}
+
+package_nginx-mainline-src() {
+ pkgdesc="Source code of nginx-mainline $pkgver, useful for building modules"
+ conflicts=($_pkgbase-src)
+ depends=()
+ install -d "$pkgdir/usr/src"
+ cp -r $_pkgbase-$pkgver-src "$pkgdir/usr/src/nginx"
+}